Results 1 to 10 of 10

Thread: Help needed in loadMovie() function!

  1. #1
    Join Date
    Aug 2003
    Location
    Ipoh,Malaysia
    Posts
    38
    Rep Power
    0

    Help needed in loadMovie() function!

    ONLY FOR EXPERIENCED FLASH PROGRAMMER!THANKS!

    Hello everybody, during i doing my flash stuff, i encounter a problem. First of all, i am using pop-up menu as the indexes to the left, then the content area to the right i using static text box and convert it to mc and provide it an instance name as "content".
    So i using the loadMovie() function to letting the "content" mc act as a view contents mc, so everything would be load to the content mc after i chosen any options at the indexes menu( act as a "flash" version frameset actually)

    Then i design another SWF file named "products"(products.swf).The content inside is the information of a Products page.

    so the loadMovie() function set to the products button in the indexes menu will be :
    on (release){
    _root.content.loadMovie("products.swf");
    }

    then i test it but the "products.swf" JUST load until it finish running a layer timeline and still got 2 layers available there. So it means others will not load and the layer that it run at the begining keeping on looping. I alrady double check the scripts but it is error free. Im not very familar with that loadMovie() function, izzit got any more scripts in that loadMovie() function that can letting us to view the "whole thing" of a external.swf in a blahblahblah.fla?

    Notice that this is a "loading external mc into a mc technique", experienced flash programmer should know what im trying to say , hopefully! Please helping me out!

    Eric

  2. #2
    Join Date
    Jun 2001
    Location
    Mystic Kingdoms
    Posts
    2,749
    Rep Power
    283
    i dont get enough the situation..

    btw, i think i has experienced about this before..

    it should be error in dot syntax(i.e _root.somethinghere... = not really true location of the mc.) and also the load LEVEL.
    maybe the loaded mc is covered by another mc. yups.. maybe like that.

    for better.. maybe u should put the example here.

  3. #3
    Join Date
    Aug 2003
    Location
    Ipoh,Malaysia
    Posts
    38
    Rep Power
    0
    Well, it is hard for me to upload that things here. Im still finding the solution for it, do u have any sense that the external SWF file will overiding the current FLA file?Im now getting more confusing.

    Okay, i repeat again. Now the problem is the FLA file will load the external file JUST at the very beginning level, after that level, it will goto the begining again for playing and this shit keep on looping, i hope there got any "using loadMovie() function" expert out there can help me out, thanks you very very much!

  4. #4
    Join Date
    Sep 2001
    Location
    Penang
    Posts
    121
    Rep Power
    227
    im quite fimiliar with loadmovie ...

    the code is ok ... for what u pasted here ....

    we walk trough one by one ::

    a few question first,

    1) is the "product.swf" is a list of product for a menu?

    Or

    2) the whole page explaning ur product ?

    if == 1
    u shouldn't be using loadmovie() ... but attachMovie() instead ...
    if == 2
    then is ok to use loadmovie()... which loaded on higher level (e.g. _level1, and making the previous movie not visible)

    ----------------------
    anyhow,

    did u put a stop(); command in product.swf ?

    or a stop(); in content MC ? .. .

    when u said it keep looping meaning product.swf is keep loading?
    --------------------

    it would be esier if u can upload the fla ... no need the complete one ... just simplifies it ....
    Last edited by kuman; 19-01-2004 at 02:21 AM.

  5. #5
    Join Date
    Aug 2003
    Location
    Ipoh,Malaysia
    Posts
    38
    Rep Power
    0
    The answer is '2':
    The whole page is all words that explaining the products.

    if == 2
    then is ok to use loadmovie()... which loaded on higher level (e.g. _level1, and making the previous movie not visible)


    I glad that u got what i am trying to tell.


    Okay, the products page got some interactivity on layers. It contains of 3 layers and each layer is a mc. So i want after the very bottom layer played, then the second layer plays, then the upper layer play,(just play it as usual, a bottom-up playing method)
    I had input the
    _root.slide1.gotoAndStop(1) command into the last frame of the mc1, instance name "slide1" for let this mc1 dissapear.(because i using the 'alpha' technique to let this mc1 appear and alpha again to let it dissapear)and a _root.slide2.gotoAndPlay(1) command into the same frame of mc1 so it will goto the next layer(mc2, named slide2) for playing.mc3 just using the same way.

    After all , i export it to products.swf and test the swf version file, it works fine, no errors. Then i want this SWF loaded into my main movie that would loaded into the content mc that i mention earlier. After I done all the things, I set the scripts that i post earlier in this topics, that is input this command:
    on (release){
    _root.content.loadMovie("products.swf");
    }

    into the button of the index menu. So user after click on the button on the menu, the products.swf will call out and loaded into the content mc.
    After all, I test the result and it works, but the products.swf just loaded "the very first layer" and it is not continuing playing others but keep on looping on the "very bottom" layers of products.swf.

    I try my best to "Descript" it to all of you, Hope u know it in more details. (Anything not clear I can say it more details again later) Type for HELP. thanks.

    Eric

  6. #6
    Join Date
    Sep 2001
    Location
    Penang
    Posts
    121
    Rep Power
    227
    if what i understand from ur posts ... i think i know wheres the problem ....

    u see in ur code :: _root.slide1.gotoAndStop(1) ...

    remember that now product.swf is loaded to the main movie ....

    the full past for it will be _root.content.slide1.gotoAndStop(1) ...

    and easy way to solve this is that u change path in product.swf as at each slide's last frame::

    //now is on slide1
    this._visible = false;
    _parent.slide2._visible = true;
    _parent.slide2.gotoAndPlay(1);
    this.gotoAndStop(1);
    *usually* the first frame of each movie should be empty and have a stop(); ... if so ... no _visible = false (alpha) is required and just ::

    _parent.slide2.gotoAndPlay(2);
    this.gotoAndStop(1);
    and so on in every slides ....

    this will make product.swf works in standalone or loaded to another swf ...

    try it ... anything not clear ... post it here ....
    Last edited by kuman; 19-01-2004 at 11:18 AM.

  7. #7
    Join Date
    Aug 2003
    Location
    Ipoh,Malaysia
    Posts
    38
    Rep Power
    0
    Thank you very much kuman, u really hit the target and solve my problem. Thanks dude.

  8. #8
    Join Date
    Sep 2001
    Location
    Penang
    Posts
    121
    Rep Power
    227
    no problem .... glad to be of help ...

  9. #9
    Join Date
    Feb 2004
    Location
    not here
    Posts
    74
    Rep Power
    196
    sometimes it's wise to use relative refferencing. it would makes the objects more flexible n modular

    (sajer nyampuk nak hidupkan topic)

  10. #10
    Join Date
    Mar 2003
    Location
    naga keramat
    Posts
    20
    Rep Power
    0
    salam,
    nyampuk gaklah...
    lama tak jadi org biasa...

    penggunaan dot.syntax....?
    selalu ramai lupa penggunaan dot.syntax nie...
    seperti masalah eric nie...
    dgn lupanya satu path dot syntax...
    habis pojek dier...
    selamatlah ade kuman....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. php ob_start function
    By Redzuan9999 in forum Website Programming
    Replies: 2
    Last Post: 04-12-2007, 10:38 AM
  2. wedding and function shooting
    By zzrmetal in forum Advertise Your Services
    Replies: 1
    Last Post: 03-09-2007, 01:26 AM
  3. newbies : loadmovie actionscript
    By antudegil in forum Website Design
    Replies: 5
    Last Post: 16-08-2007, 12:27 PM
  4. print function
    By ardella in forum Website Programming
    Replies: 2
    Last Post: 13-05-2004, 12:50 AM
  5. stripslashes() function for JSP?
    By lcf in forum Website Programming
    Replies: 3
    Last Post: 21-04-2004, 10:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search Engine Optimization by vBSEO 3.5.0 RC1 PL1

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112